Currency Assistant 3.4.1

Requires macOS 10.11 (including macOS 11.0 Big Sur)
and runs natively on Apple Silicon and Intel-based Macs

Currency Assistant runs in English, German, French, Dutch, and Italian.

Legacy Versions

Currency Assistant 3.2.9

Requires macOS 10.6 Snow Leopard to 10.13 High Sierra.

Currency Assistant 3.1.12

Requires macOS 10.4 Tiger to 10.9 Mavericks.